summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Bockover <abock@gnome.org>2008-10-24 23:53:39 +0000
committerAaron Bockover <abock@src.gnome.org>2008-10-24 23:53:39 +0000
commit2c4460b9daf29ec6359d3246ef1b56275356e1a7 (patch)
tree93c4343a2833244524556edbb3e1b6cb81a299ff /Makefile.am
parent0561a303a96d8f4816950b60934152a13c50a18a (diff)
Patch from patch-master-organizer Bertrand Lorentz to allow localized
2008-10-24 Aaron Bockover <abock@gnome.org> * Makefile.am: Patch from patch-master-organizer Bertrand Lorentz to allow localized uninstalled instances ala 'make run'; his make foo is strong (BGO #393046) svn path=/trunk/banshee/; revision=4740
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cc9aa84a8..ffd00a2c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,15 @@ uninstall-hook:
# Developer targets
-run:
+LC_BUILD = $(top_builddir)/bin/share/locale
+PO_FILES = $(addprefix po/, $(addsuffix .gmo, $(ALL_LINGUAS)))
+MO_FILES = $(patsubst po/%.gmo, $(LC_BUILD)/%/LC_MESSAGES/$(PACKAGE).mo, $(PO_FILES))
+
+$(MO_FILES): $(LC_BUILD)/%/LC_MESSAGES/$(PACKAGE).mo: po/%.gmo
+ $(mkdir_p) $(dir $@)
+ cp -af '$<' '$@'
+
+run: $(MO_FILES)
@pushd bin; \
$(MONO) --debug $(BANSHEE_DEV_MONO_OPTIONS) Nereid.exe --debug --uninstalled $(BANSHEE_DEV_OPTIONS); \
popd;