summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel Burt <gabriel.burt@gmail.com>2009-03-11 23:08:08 +0000
committerGabriel Burt <gburt@src.gnome.org>2009-03-11 23:08:08 +0000
commit144c0638aa7139c6edaca0ef337eadd495254e6d (patch)
treec050f05344a50d486430e77e14e24e5b91fcca08 /Makefile.am
parentfd6d0583805731183d5cb8af7208e30e6f9c516f (diff)
Add 'make csharp' target that references Gtk#, Hyena, Banshee etc for
2009-03-11 Gabriel Burt <gabriel.burt@gmail.com> * Makefile.am: Add 'make csharp' target that references Gtk#, Hyena, Banshee etc for convenient/quick shell usage. svn path=/trunk/banshee/; revision=5129
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f30b6c90a..f4be9e9b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,13 @@ mdb:
mdb -run -args Nereid.exe --debug --uninstalled"; \
popd;
+csharp:
+ @pushd .; \
+ echo ""; \
+ echo "Starting csharp with Gtk#, Hyena, Banshee, etc referenced"; \
+ csharp -lib:bin/ -pkg:glib-sharp-2.0 -pkg:gtk-sharp-2.0 -pkg:gconf-sharp-2.0 -pkg:dbus-sharp -pkg:taglib-sharp -pkg:ipod-sharp -pkg:mono-addins $(addprefix "-reference:", $(wildcard bin/*.dll)); \
+ popd;
+
test:
@pushd tests; \
make test \