summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2012-07-06 16:35:50 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2012-07-06 16:35:50 +1000
commitf94bbe302c749a736ce0506c7d4d4af11ad93121 (patch)
tree11147c367977d0c350dc9d72e116894dad1a27bc /configure.ac
initial setup for X.Org testing through googletestxorg-integration-tests-0.0.1
Includes a basic test that should bring up an acecad device and test for its presence. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..703aec4
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,53 @@
+# Copyright 2012 Red Hat, Inc.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+#
+# Process this file with autoconf to produce a configure script
+
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([RHEL-XOrg-testing], [0.0.1])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR(.)
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
+AM_MAINTAINER_MODE
+
+# Initialize libtool
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+AC_PROG_CXX
+
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.17 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.17)
+XORG_DEFAULT_OPTIONS
+XORG_ENABLE_INTEGRATION_TESTS(yes)
+
+PKG_CHECK_MODULES(XI, x11 [xi >= 1.6])
+PKG_CHECK_MODULES(EVEMU, utouch-evemu)
+PKG_CHECK_MODULES(XORGGTEST, xorg-gtest)
+
+CHECK_XORG_GTEST
+
+AC_CONFIG_FILES([Makefile
+ tests/Makefile])
+AC_OUTPUT