summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-01-23 13:50:42 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-01-23 13:50:42 -0500
commit7d498b4f1a4669e916090483a91481b1b9a97f4a (patch)
treeef279355535f1f10d0bd548d92b6ccc7b283adf6 /configure.ac
parent6fea3dc5ced1737d644a2b657c93442f401cdcb6 (diff)
Enable all compositors by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bcc1e83..0f6f9ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,14 +39,16 @@ if test x$enable_x11_compositor == xyes; then
fi
-AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor])
+AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor],,
+ enable_drm_compositor=yes)
AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor == xyes)
if test x$enable_drm_compositor == xyes; then
AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
fi
-AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor])
+AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
+ enable_wayland_compositor=yes)
AM_CONDITIONAL(ENABLE_WAYLAND_COMPOSITOR,
test x$enable_wayland_compositor == xyes)
if test x$enable_wayland_compositor == xyes; then