summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHenrik Rydberg <rydberg@euromail.se>2010-09-18 19:10:11 +0200
committerHenrik Rydberg <rydberg@euromail.se>2010-09-18 19:10:11 +0200
commit9bec5056ec35008afd4d68528718fd4519cd3503 (patch)
tree886fb51f744ed50a1fbdf6615f80be513fa488f0 /configure.ac
Initial evemu commit
Evemu is a kernel device and emulator, which allows for remote creation and testing of arbitrary devices. Signed-off-by: Henrik Rydberg <rydberg@euromail.se>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..58c140d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([Kernel device emulation],
+ [1.0.0],
+ [],
+ [evemu])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([config-aux])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+LIB_VERSION=1:0:0
+AC_SUBST([LIB_VERSION])
+
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ tools/Makefile
+ evemu.pc])
+AC_OUTPUT