summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2008-02-28 02:07:21 +0000
committerDan Williams <dcbw@redhat.com>2008-02-28 02:07:21 +0000
commit8ffe21b65fdcbdd3238548b0350571fbe3ac8713 (patch)
tree21e9521a96afa61145fbbd4d4eeac6d90e83d5dc /Makefile.am
parent036e09cb49e10790352622e38b459c5218fe93be (diff)
2008-02-27 Dan Williams <dcbw@redhat.com>
Patch from Will Stephenson <wstephenson@kde.org> * Makefile.am configure.in - Set up spec autogeneration infrastructure * docs/NetworkManager DBUS API.txt - Note how old this doc is and where to look for the canonical D-Bus specification * introspection/* - Add annotations and comments git-svn-id: http://svn-archive.gnome.org/svn/NetworkManager/trunk@3345 4912f4e0-d625-0410-9fb7-b9a5a253dbdc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 59a4c1dd..b037bef1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,26 @@
+if WITH_DOCS
+
+all:
+
+XSLTPROC = xsltproc --xinclude --nonet
+
+XMLS = $(wildcard introspection/nm-*.xml)
+# Figure out if we need ASYNC_INTROSPECT and add it later
+
+GENERATED_FILES = \
+ docs/spec.html
+
+docs/spec.html: $(XMLS) introspection/all.xml introspection/generic-types.xml introspection/errors.xml introspection/vpn-errors.xml tools/doc-generator.xsl introspection/generic-types.xml
+ @install -d docs
+ $(XSLTPROC) tools/doc-generator.xsl introspection/all.xml > $@
+
+all: $(GENERATED_FILES)
+
+clean:
+ rm -f $(GENERATED_FILES)
+
+endif
+
SUBDIRS = \
libnm-util \
libnm-glib \