summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2018-04-25 13:46:48 +0200
committerJan Holesovsky <kendy@collabora.com>2018-04-25 13:50:24 +0200
commit737d0beea48135a8c7ac7114bab6a977dcf66c3d (patch)
treef3c8e7ec5391b46c2d117b8c3cd1e8347f5306ec /Makefile.am
parent6a0fcdf15faff87da3d5431316777a85f4b3773c (diff)
Targed for running loolwsd under gdb.
Change-Id: Id3e946f90b7e61d67b2cee34276a58501380b96d Reviewed-on: https://gerrit.libreoffice.org/53447 Reviewed-by: Jan Holesovsky <kendy@collabora.com> Tested-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6aedc561c..19e575860 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -265,6 +265,20 @@ run-valgrind: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
--o:admin_console.username=admin --o:admin_console.password=admin \
--o:logging.file[@enable]=false --o:logging.level=trace
+run-gdb: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
+ @echo "Launching loolwsd under valgrind's callgrind"
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
+ @cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
+ gdb --tui --args \
+ ./loolwsd --nocaps \
+ --o:sys_template_path="@SYSTEMPLATE_PATH@" --o:lo_template_path="@LO_PATH@" \
+ --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
+ --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
+ --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
+ --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=false --o:logging.level=error
+
run-callgrind: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
@echo "Launching loolwsd under valgrind's callgrind"
@fc-cache "@LO_PATH@"/share/fonts/truetype