summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2012-02-08 12:46:57 -0500
committerKristian Høgsberg <krh@bitplanet.net>2012-02-08 12:46:57 -0500
commit3d5437c48d17cb4bf5c861d62ce59e4f9d490050 (patch)
treefd48c16b56fae9410b74d89847c05ef1ff3d5fc2 /configure.ac
parent902865c757f96923cc6ef90107fffcbadb6bbf4a (diff)
Add support for webp image format
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a2bb537..02f4040 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,11 +123,16 @@ if test x$enable_clients == xyes; then
[have_poppler=yes], [have_poppler=no])
PKG_CHECK_MODULES(CAIRO_EGL, [cairo-egl >= 1.11.3 $cairo_modules],
[have_cairo_egl=yes], [have_cairo_egl=no])
-
AS_IF([test "x$have_cairo_egl" = "xyes"],
[AC_DEFINE([HAVE_CAIRO_EGL], [1], [Have cairo-egl])],
[AC_MSG_WARN([Cairo-EGL not found - clients will use cairo image])])
+ PKG_CHECK_MODULES(WEBP, [libwebp], [have_webp=yes], [have_webp=no])
+ AS_IF([test "x$have_webp" = "xyes"],
+ [AC_DEFINE([HAVE_WEBP], [1], [Have webp])])
+ CLIENT_LIBS="$CLIENT_LIBS $WEBP_LIBS"
+ CLIENT_CFLAGS="$CLIENT_CFLAGS $WEBP_CFLAGS"
+
AC_CHECK_LIB([jpeg], [jpeg_CreateDecompress], have_jpeglib=yes)
if test x$have_jpeglib == xyes; then
CLIENT_LIBS="$CLIENT_LIBS -ljpeg"