summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobled <nobled@dreamwidth.org>2011-01-28 13:47:21 +0000
committernobled <nobled@dreamwidth.org>2011-01-28 13:47:21 +0000
commit48f975d7c574927befee4f27d2c93f43a78585cf (patch)
tree22cf766e46bc627e82b89e5d2372a20dc4a8d89f /configure.ac
parent26ef22e3f479259890bf856a66a8a5fbf6fc7d30 (diff)
fix configure check for gcc
This shouldn't fail just because someone sets CC=gcc-4.5 explicitly. Besides, this way it also works with compilers that advertise GCC-compatibility like clang and ICC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 226d87c..a4cfcbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ PKG_CHECK_MODULES(CAIRO_EGL, [cairo-egl],
AS_IF([test "x$have_cairo_egl" = "xyes"],
[AC_DEFINE([HAVE_CAIRO_EGL], [1], [Have cairo-egl])])
-if test $CC = gcc; then
+if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-Wall -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
fi
AC_SUBST(GCC_CFLAGS)