summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2010-10-29 15:20:18 +0800
committerKristian Høgsberg <krh@bitplanet.net>2010-10-29 12:52:28 -0400
commit1b6c0ed95a8b9c98bca0728cdf56159cc57fec45 (patch)
tree8b56ff79e089c43caa1622dc363345fd9972c731 /configure.ac
parent4d8ba216c543239d4419eebd41120ce74033cf2b (diff)
Workaround an xcb-dri2 bug.
xcb_dri2_connect_device_name generated by xcb-proto 1.6 is broken. It only works when the length of the driver name is a multiple of 4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b510b51..f57e2bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,11 @@ AC_CHECK_LIB(expat, XML_ParserCreate, [EXPAT_LIBS="-lexpat"],
[AC_MSG_ERROR([Can't find expat library. Please install expat.])])
AC_SUBST(EXPAT_LIBS)
+# workaround a bug in xcb-dri2 generated by xcb-proto 1.6
+AC_CHECK_LIB(xcb-dri2, xcb_dri2_connect_alignment_pad, [],
+ [AC_DEFINE([XCB_DRI2_CONNECT_DEVICE_NAME_BROKEN], [1],
+ [Define to 1 if xcb_dri2_connect_device_name is broken])])
+
AC_CONFIG_FILES([wayland/wayland-server.pc
wayland/wayland-client.pc
Makefile