summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-03-10 10:25:10 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-03-10 16:46:55 +0100
commit6f379eeba97eb8cf60a18591c19c0763b1636417 (patch)
treed622d111072184a2fbff5f8abb3e7991561dc875 /configure.ac
parent79fb87e9cbadddd038119b5ddee67cb49a7c4808 (diff)
build-sys: Fix setting of SPICE_GTK_MICRO_VERSION
After e124a3b2e which added the SPICE_GTK_CHECK_VERSION macro, a non-fatal './configure: line 15251: x24: command not found' appears in configure output. This is because [ ] is not interpreted as the 'test' command by autoconf, but is rather used as a way to quote configure.ac content. This commit replaces the use of [] with a more typical AS_IF.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 192d748..afdbdbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,7 +78,7 @@ AC_SUBST(COMMON_CFLAGS)
SPICE_GTK_MAJOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f1`
SPICE_GTK_MINOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f2`
SPICE_GTK_MICRO_VERSION=`echo $PACKAGE_VERSION | cut -d. -f3 | cut -d- -f1`
-[ "x$SPICE_GTK_MICRO_VERSION" = "x" ] && SPICE_GTK_MICRO_VERSION = 0
+AS_IF([test "x$SPICE_GTK_MICRO_VERSION" = "x"], [SPICE_GTK_MICRO_VERSION = 0])
AC_SUBST(SPICE_GTK_MAJOR_VERSION)
AC_SUBST(SPICE_GTK_MINOR_VERSION)