summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-02-14 14:25:32 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-02-20 11:52:33 +0100
commitaece5f02f62d6d482404c78abda2e58c168f54d6 (patch)
tree6b6290f6dbe3ae6ae1c04108d6b99e5a45593eb6 /Makefile.am
parentd28d6e11d20a562a93f23edf1e2a41019ecf6be0 (diff)
build-sys: Don't build tests when not building static libs
The tests rely on static linking in order to get access to symbols which are not exported in spice-gtk shared libraries. When build of static libraries is disabled with --disable-static, we should not attempt to build the tests as this will result in link errors.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ab10f5f..8add19f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,11 @@
ACLOCAL_AMFLAGS = -I m4
NULL =
-SUBDIRS = spice-common gtk po doc data tests
+SUBDIRS = spice-common gtk po doc data
+
+if BUILD_TESTS
+SUBDIRS += tests
+endif
if HAVE_INTROSPECTION
if WITH_VALA