summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2010-11-25 21:12:25 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2010-11-25 21:12:25 +0100
commit27b06760f3a381acba9f840bab1a3ea2efc7ffde (patch)
tree1badeccc6f64d7c6f818bdd7caf7eb6a0edf28bb /Makefile.am
parent1c14108f906090d2140b019be23ee31e7772acae (diff)
build: use git-version-gen
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b9e1228..1911eff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,19 @@ DISTCLEANFILES = $(pkgconfig_DATA) \
intltool-update \
po/.intltool-merge-cache
-EXTRA_DIST = spice.proto spice1.proto spice_codegen.py $(INTLTOOL_FILES)
+EXTRA_DIST = spice.proto \
+ spice1.proto \
+ spice_codegen.py \
+ build-aux/git-version-gen \
+ .version \
+ $(INTLTOOL_FILES)
+
+# see git-version-gen
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection