summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2010-11-24 04:35:55 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2010-11-24 04:37:16 +0100
commit1fc30e01d5171cd7928716d86cc5666890695dfb (patch)
treeda261db5fa9aa0ac6453c86c983fc2d8020c58d1 /Makefile.am
parentbfeff569ca666b879803522f5bb0d68f6d82d363 (diff)
i18: add basic support - mark translatable spicy strings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ac65f2..b9e1228 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,20 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = common gtk python_modules
+SUBDIRS = common gtk po python_modules
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = spice-client-glib.pc spice-client-gtk.pc
-DISTCLEANFILES = $(pkgconfig_DATA)
+INTLTOOL_FILES = intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
-EXTRA_DIST = spice.proto spice1.proto spice_codegen.py
+DISTCLEANFILES = $(pkgconfig_DATA) \
+ intltool-extract \
+ intltool-merge \
+ intltool-update \
+ po/.intltool-merge-cache
+
+EXTRA_DIST = spice.proto spice1.proto spice_codegen.py $(INTLTOOL_FILES)
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection