summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Sedov <radist.morse@gmail.com>2015-08-05 01:38:55 +0300
committerBastien Nocera <hadess@hadess.net>2015-08-31 16:10:23 +0200
commit8b18594e65fc1196c1d270ee3fcefe55195ea397 (patch)
tree5d044c0efc98910e07437768c869446a6d8a5ac5 /configure.ac
parente88d6e5561293e2e62d0b63b63038d2de9fc096d (diff)
lua-factory: Stricter integer typization for Lua
Lua 5.3 introduced a new integer type to Lua. Now it should be used instead of previous "number" whenever applicable. https://bugzilla.gnome.org/show_bug.cgi?id=753141
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0e1353f..7112cf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,9 +130,9 @@ PKG_CHECK_MODULES(GDATA, libgdata >= 0.9.1, HAVE_GDATA=yes, HAVE_GDATA=no)
PKG_CHECK_MODULES(LIBSOUP, libsoup-2.4, HAVE_LIBSOUP=yes, HAVE_LIBSOUP=no)
-PKG_CHECK_MODULES(LUA, lua >= 5.2.0,
+PKG_CHECK_MODULES(LUA, lua >= 5.3.0,
HAVE_LUA=yes,
- [PKG_CHECK_MODULES(LUA, lua5.2 >= 5.2.0,
+ [PKG_CHECK_MODULES(LUA, lua5.3 >= 5.3.0,
HAVE_LUA=yes,
HAVE_LUA=no)])