summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2014-04-18 21:14:28 +0200
committerBastien Nocera <hadess@hadess.net>2014-05-07 18:17:24 +0200
commit714c03643329fcfd0518637d859336954699a28c (patch)
tree51f30e1f4703a3baa6121d7b03550af2de4ec47a /configure.ac
parentca486211e03fd280136d846d2b75cb7ff4fea46b (diff)
lua-factory: Add grl.unzip library function
Script developers can use this to fetch a zip file, and extract particular files inside that zip file. This also adds a libarchive dependency for the lua-factory plugin. https://bugzilla.gnome.org/show_bug.cgi?id=728525
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5215451..50b4fda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,6 +140,8 @@ PKG_CHECK_MODULES(LUA, lua >= 5.2.0,
HAVE_LUA=yes,
HAVE_LUA=no)])
+PKG_CHECK_MODULES(ARCHIVE, libarchive, HAVE_ARCHIVE=yes, HAVE_ARCHIVE=no)
+
PKG_CHECK_MODULES(GTHREAD, gthread-2.0, HAVE_GTHREAD=yes, HAVE_GTHREAD=no)
PKG_CHECK_MODULES(OAUTH, oauth, HAVE_OAUTH=yes, HAVE_OAUTH=no)
@@ -847,6 +849,9 @@ AC_ARG_ENABLE(lua_factory,
if test "x$HAVE_LUA" = "xno"; then
AC_MSG_ERROR([lua not found, install it or use --disable-lua-factory])
fi
+ if test "x$HAVE_ARCHIVE" = "xno"; then
+ AC_MSG_ERROR([libarchive not found, install it or use --disable-lua-factory])
+ fi
if test "x$HAVE_GRLNET" = "xno"; then
AC_MSG_ERROR([grilo-net not found, install it or use --disable-lua-factory])
fi
@@ -857,7 +862,7 @@ AC_ARG_ENABLE(lua_factory,
esac
],
[
- if test "x$HAVE_LUA" = "xyes" -a "x$HAVE_GRLNET" = "xyes" -a "x$HAVE_JSON_GLIB" = "xyes"; then
+ if test "x$HAVE_LUA" = "xyes" -a "x$HAVE_ARCHIVE" = "xyes" -a "x$HAVE_GRLNET" = "xyes" -a "x$HAVE_JSON_GLIB" = "xyes"; then
enable_lua_factory=yes
else
enable_lua_factory=no
@@ -875,9 +880,9 @@ LUA_FACTORY_PLUGIN_ID="grl-lua-factory"
AC_SUBST(LUA_FACTORY_PLUGIN_ID)
AC_DEFINE_UNQUOTED([LUA_FACTORY_PLUGIN_ID], ["$LUA_FACTORY_PLUGIN_ID"], [Lua Factory plugin ID])
-DEPS_LUA_FACTORY_CFLAGS="$DEPS_CFLAGS $LUA_CFLAGS $GRLNET_CFLAGS $JSON_CFLAGS"
+DEPS_LUA_FACTORY_CFLAGS="$DEPS_CFLAGS $LUA_CFLAGS $ARCHIVE_CFLAGS $GRLNET_CFLAGS $JSON_CFLAGS"
AC_SUBST(DEPS_LUA_FACTORY_CFLAGS)
-DEPS_LUA_FACTORY_LIBS="$DEPS_LIBS $LUA_LIBS $GRLNET_LIBS $JSON_LIBS"
+DEPS_LUA_FACTORY_LIBS="$DEPS_LIBS $LUA_LIBS $ARCHIVE_LIBS $GRLNET_LIBS $JSON_LIBS"
AC_SUBST(DEPS_LUA_FACTORY_LIBS)
LUA_FACTORY_SOURCE_LOCATION="grilo-plugins/${LUA_FACTORY_PLUGIN_ID}"