summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2014-07-01 11:42:56 -0700
committerChad Versace <chad.versace@linux.intel.com>2014-07-15 07:16:15 -0700
commite284bd7f1c235fee66b9ace28b4618501a24777f (patch)
treec4645d9cdfa6e1a9cc95d54067b52dbb0273750e /CMakeLists.txt
parent537b0dcb178dd944b8e2095ba3d7adab54fac003 (diff)
cmake: Fix Mac build error from commit 62a4aab9
Commit 62a4aab9 set the CMake property LINK_INTERFACE_LIBRARIES to empty for libwaffle, because Debian's packaging tools complained otherwise. Afterwards, Waffle's CMake neglected to declare the Cocoa library dependencies for the executables wflinfo, gl_basic, gl_basic_test. Post-commit, the executables were no longer satisying their Cocoa dependency transitively through libwaffle. Fix the build by linking *every* Waffle target to the Cocoa libraries with a toplevel `link_libraries` directive. Also, don't unset LINK_INTERFACE_LIBRARIES on the Mac. It causes a CMake warning that I don't understand. Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf19929..8e62e40 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,13 @@ add_custom_target(check-func
# Add subdirectories
# ------------------------------------------------------------------------------
+if(waffle_on_mac)
+ link_libraries(
+ ${COCOA_FRAMEWORK}
+ ${CORE_FOUNDATION_FRAMEWORK}
+ )
+endif()
+
include_directories(
include
include/waffle