summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2013-08-18 10:21:48 -0700
committerChad Versace <chad.versace@linux.intel.com>2013-08-19 23:04:47 -0700
commitbc298fa384a0b928e6b9de1b9f2f0091bd2b90b5 (patch)
tree5ce590aaaa4a0d487c6da116c928076de6a3bdb9 /CMakeLists.txt
parenteebc0fd464ebebc2dbfbd3db8f57c6ee8df28ce9 (diff)
cmake,readme: Move Waffle's CMake options to new file Options.cmake
This makes it easy for users to find all the custom CMake options defined by Waffle. Update the README accordingly. Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 1 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfbcdb0..2714b83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,7 @@ set(waffle_soversion "0")
# Includes
# ------------------------------------------------------------------------------
+include(Options.cmake)
include(CheckThreadLocalStorage)
#
@@ -74,35 +75,6 @@ set(PROJECT_NAME "waffle")
find_package(PkgConfig)
-
-# ------------------------------------------------------------------------------
-# Waffle Options
-# ------------------------------------------------------------------------------
-
-# All options here are prefixed with `waffle_`. Most options are cache
-# variables set by the user.
-
-# ----------------------------------------------
-# Set waffle options
-# ----------------------------------------------
-
-option(waffle_build_tests "Build tests" ON)
-
-# Most users don't have the necessary tools installed to build from
-# Docbook sources, so require users to explicitly enable building them.
-option(waffle_build_manpages "Build manpages" OFF)
-option(waffle_build_htmldoc "Build html documentation" OFF)
-
-option(waffle_build_examples "Build examples" ON)
-
-option(waffle_has_glx "Build support for GLX" OFF)
-option(waffle_has_wayland "Build support for Wayland" OFF)
-option(waffle_has_x11_egl "Build support for X11/EGL" OFF)
-option(waffle_has_gbm "Build support for GBM" OFF)
-
-set(waffle_xsltproc "xsltproc"
- CACHE STRING "Tool used to process XSLT stylesheets")
-
# ----------------------------------------------
# Emit errors for removed options
# ----------------------------------------------