summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorX512 <danger_mail@list.ru>2021-01-04 22:10:08 -0600
committerAlexander von Gluck IV <kallisti5@unixzen.com>2021-01-09 20:51:08 -0600
commit97520d8d48036c64585dd057001fa96868ed01c7 (patch)
treee654b971191505d018b49970313faed7f351a22e /meson.build
parent71f4a743686dbbbe51213fee1489dfecf35b079d (diff)
util/meson: Add libnetwork dependency for Haiku
Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8323>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 965e14ff2e9..719da783c32 100644
--- a/meson.build
+++ b/meson.build
@@ -448,7 +448,7 @@ endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
use_elf_tls = false
-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+if not ['windows', 'freebsd', 'openbsd', 'haiku'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
pre_args += '-DUSE_ELF_TLS'
use_elf_tls = true
endif
@@ -1418,6 +1418,10 @@ endif
# it's not linux and wont
dep_m = cc.find_library('m', required : false)
+if with_platform_haiku
+ dep_network = cc.find_library('network')
+endif
+
# Check for libdrm. Various drivers have different libdrm version requirements,
# but we always want to use the same version for all libdrm modules. That means
# even if driver foo requires 2.4.0 and driver bar requires 2.4.3, if foo and