summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2015-04-22 22:06:18 +0200
committerKay Sievers <kay@vrfy.org>2015-04-22 22:10:28 +0200
commit58a26e1269619975ed2b8ea94b245c358cd1e29d (patch)
tree0a21e8e653271d7f3969e6da94beb933ab781d39 /Makefile.am
parent7375b3c4871861f100860ea4c2848e66b60e6ca4 (diff)
build-sys: adjust link-order for non-gc-sections build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index af32d2a02..be7e9a211 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5489,8 +5489,8 @@ systemd_pull_CFLAGS = \
-D USER_KEYRING_PATH=\"$(pkgsysconfdir)/import-pubring.gpg\"
systemd_pull_LDADD = \
- libsystemd-internal.la \
libsystemd-label.la \
+ libsystemd-internal.la \
libsystemd-shared.la \
$(LIBCURL_LIBS) \
$(XZ_LIBS) \
@@ -5517,8 +5517,8 @@ systemd_import_CFLAGS = \
$(ZLIB_CFLAGS)
systemd_import_LDADD = \
- libsystemd-internal.la \
libsystemd-label.la \
+ libsystemd-internal.la \
libsystemd-shared.la \
$(XZ_LIBS) \
$(ZLIB_LIBS) \
@@ -5541,8 +5541,8 @@ systemd_export_CFLAGS = \
$(ZLIB_CFLAGS)
systemd_export_LDADD = \
- libsystemd-internal.la \
libsystemd-label.la \
+ libsystemd-internal.la \
libsystemd-shared.la \
$(XZ_LIBS) \
$(ZLIB_LIBS) \