summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-04-11 10:23:22 +0200
committerDavid Herrmann <dh.herrmann@gmail.com>2015-04-11 11:39:29 +0200
commit32ef61b88864e0de2edd8dbadfc315ee4c353324 (patch)
treef791633bbf465f20d0bd0796a3e965e5aab62ff2 /Makefile.am
parent3ebc2dc49837e38288e1bcaa0f1632cc6c897232 (diff)
build: support non-x86 EFI builds
Move the no-mmx/no-sse CFLAGS to X86-64 and IA32 defines in preparation for ARM32 and Aarch64 support.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ff74bbdc..f30fe296a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2564,17 +2564,23 @@ efi_cflags = \
-fno-strict-aliasing \
-fno-stack-protector \
-Wsign-compare \
- -Wno-missing-field-initializers \
- -mno-sse \
- -mno-mmx
+ -Wno-missing-field-initializers
if ARCH_X86_64
efi_cflags += \
-mno-red-zone \
+ -mno-sse \
+ -mno-mmx \
-DEFI_FUNCTION_WRAPPER \
-DGNU_EFI_USE_MS_ABI
endif
+if ARCH_IA32
+efi_cflags += \
+ -mno-sse \
+ -mno-mmx
+endif
+
efi_ldflags = \
$(EFI_LDFLAGS) \
-T $(EFI_LDS_DIR)/elf_$(EFI_ARCH)_efi.lds \