summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonny Chevalier <chevalier.ronny@gmail.com>2015-04-10 23:15:59 +0200
committerRonny Chevalier <chevalier.ronny@gmail.com>2015-04-11 00:34:02 +0200
commit288a74cce597f81d3ba01d8a5ca7d2ba5b654b7e (patch)
tree66f8131648bd8ba51e7039f7b7be712e1a5f494e /Makefile.am
parent3df3e884ae1237ef0d4d23b0e80f4ffda95ac135 (diff)
shared: add terminal-util.[ch]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f348ef90f..114d4a104 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -903,6 +903,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/process-util.h \
src/shared/random-util.c \
src/shared/random-util.h \
+ src/shared/terminal-util.c \
+ src/shared/terminal-util.h \
src/shared/uid-range.c \
src/shared/uid-range.h \
src/shared/nss-util.h \
@@ -1394,6 +1396,7 @@ tests += \
test-ellipsize \
test-util \
test-process-util \
+ test-terminal-util \
test-path-lookup \
test-ring \
test-barrier \
@@ -1675,6 +1678,12 @@ test_process_util_SOURCES = \
test_process_util_LDADD = \
libsystemd-shared.la
+test_terminal_util_SOURCES = \
+ src/test/test-terminal-util.c
+
+test_terminal_util_LDADD = \
+ libsystemd-shared.la
+
test_path_lookup_SOURCES = \
src/test/test-path-lookup.c