summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2012-07-03 09:27:17 +0100
committerTim-Philipp Müller <tim@centricular.net>2012-07-03 09:27:37 +0100
commit9822ebb0b07662b8de4d673088b2537ca02e090e (patch)
treece8dcacaeb59c3a38d91268538151a388f366714 /configure.ac
parentc740490c26d19422e2bc51b9b068253bc93549be (diff)
configure: require Gtk+ 3.0 for tests/examples
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index c2d306b0b..11612c6d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,21 +234,8 @@ AC_SUBST(GSTPB_PREFIX)
dnl GTK is optional and used in examples
HAVE_GTK=no
-GTK2_REQ=2.14.0
-GTK3_REQ=2.91.3
+GTK_REQ=3.0.0
if test "x$BUILD_EXAMPLES" = "xyes"; then
- AC_MSG_CHECKING([which gtk+ version to compile examples against (optional)])
- AC_ARG_WITH([gtk],
- AC_HELP_STRING([--with-gtk=3.0|2.0],
- [which gtk+ version to compile against (default: 2.0)]),
- [case "$with_gtk" in
- 2.0) GTK_REQ=$GTK2_REQ ;;
- 3.0) GTK_REQ=$GTK3_REQ ;;
- *) AC_MSG_ERROR([invalid gtk+ version specified]);;
- esac],
- [with_gtk=2.0
- GTK_REQ=$GTK2_REQ])
- AC_MSG_RESULT([$with_gtk (>= $GTK_REQ)])
PKG_CHECK_MODULES(GTK, gtk+-$with_gtk >= $GTK_REQ, HAVE_GTK=yes, HAVE_GTK=no)
dnl some examples need gtk+-x11
PKG_CHECK_MODULES(GTK_X11, gtk+-x11-$with_gtk >= $GTK_REQ, HAVE_GTK_X11=yes, HAVE_GTK_X11=no)