summaryrefslogtreecommitdiff
path: root/open-vm-tools/guestproxycerttool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'open-vm-tools/guestproxycerttool/Makefile.am')
-rw-r--r--open-vm-tools/guestproxycerttool/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/open-vm-tools/guestproxycerttool/Makefile.am b/open-vm-tools/guestproxycerttool/Makefile.am
new file mode 100644
index 00000000..4c622b3c
--- /dev/null
+++ b/open-vm-tools/guestproxycerttool/Makefile.am
@@ -0,0 +1,42 @@
+################################################################################
+### Copyright (C) 2014-2015 VMware, Inc. All rights reserved.
+###
+### This program is free software; you can redistribute it and/or modify
+### it under the terms of version 2 of the GNU General Public License as
+### published by the Free Software Foundation.
+###
+### This program is distributed in the hope that it will be useful,
+### but WITHOUT ANY WARRANTY; without even the implied warranty of
+### MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+### GNU General Public License for more details.
+###
+### You should have received a copy of the GNU General Public License
+### along with this program; if not, write to the Free Software
+### Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+################################################################################
+
+bin_PROGRAMS = vmware-guestproxycerttool
+
+vmware_guestproxycerttool_LDADD =
+vmware_guestproxycerttool_LDADD += @SSL_LIBS@
+vmware_guestproxycerttool_LDADD += -lcrypto
+vmware_guestproxycerttool_LDADD += @GLIB2_LIBS@
+
+vmware_guestproxycerttool_CPPFLAGS =
+vmware_guestproxycerttool_CPPFLAGS += @SSL_CPPFLAGS@
+vmware_guestproxycerttool_CPPFLAGS += @GLIB2_CPPFLAGS@
+
+vmware_guestproxycerttool_SOURCES =
+vmware_guestproxycerttool_SOURCES += cert_key.c
+vmware_guestproxycerttool_SOURCES += cert_util.c
+vmware_guestproxycerttool_SOURCES += cert_tool.c
+
+if HAVE_ICU
+ vmware_guestproxycerttool_LDADD += @ICU_LIBS@
+ vmware_guestproxycerttool_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CXX) \
+ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
+ $(LDFLAGS) -o $@
+else
+ vmware_guestproxycerttool_LINK = $(LINK)
+endif