summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-12-17 19:59:42 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-12-17 19:59:42 +0000
commit8ee3b441e0252030aacbb2142ffb479accf7b845 (patch)
treee6d66af707fbe9ef0ceac5e007c73c1c2e53f967 /Makefile.am
parent8a695165c2c95360b7fb8e47196e4a6f19a986de (diff)
Makefile.am: The check-exports stuff moved to common/win32.mak, so include that.
Original commit message from CVS: * Makefile.am: The check-exports stuff moved to common/win32.mak, so include that.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 098b82ce9..ada3d7aa8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,10 +23,8 @@ DIST_SUBDIRS = \
pkgconfig po \
common
-win32 = $(shell cat $(top_srcdir)/win32/MANIFEST)
-
-debug:
- echo $(win32)
+# include before EXTRA_DIST for win32 assignment
+include $(top_srcdir)/common/win32.mak
EXTRA_DIST = \
gstreamer.spec gstreamer.spec.in \
@@ -113,20 +111,5 @@ win32-update:
include $(top_srcdir)/common/coverage/lcov.mak
-# make sure all symbols we export on linux are defined in the win32 .def too
-# (don't care about other unixes for now, it's enough if it works on one of
-# the linux build bots; we assume .so )
-corelibs='libgstreamer libgstbase libgstcontroller libgstdataprotocol libgstnet'
-check-exports:
- for l in `eval echo $(corelibs)`; do \
- libso=`find "$(top_builddir)" -name "$$l-0.10.so"`; \
- libdef="$(top_srcdir)/win32/common/$$l.def"; \
- if test "x$$libso" != "x"; then \
- echo Checking symbols in $$libso; \
- $(top_srcdir)/common/check-exports $$libdef $$libso || exit 1; \
- fi; \
- done
-
check: check-exports
-