summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier CrĂȘte <tester@tester.ca>2014-03-16 23:19:55 -0400
committerOlivier CrĂȘte <tester@tester.ca>2014-03-16 23:19:55 -0400
commit8096d82fd1b52be9853703cd771c75db20a60230 (patch)
tree03c89ef4b3183ab1cf0cb54cbdab4a0bcd737ba7 /configure.ac
parentcfa58778992aef5ab229ab6a2421db6f86c0dd29 (diff)
configure: Don't fail if gudev is not present
PKG_CHECK_MODULES has the bad habit of failing the build if it doesn't get what it wants, prevent that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f05434c56..282f511fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,7 +522,8 @@ if test x$with_gudev != xno; then
PKG_CHECK_MODULES(GUDEV, [ gudev-1.0 >= 147 ],
[ AC_DEFINE(HAVE_GUDEV, 1,
[Whether gudev is available for device detection])
- ])
+ ],
+ [true])
fi
AC_SUBST(GUDEV_CFLAGS)