summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2015-09-10 00:07:18 +1000
committerMatthew Waters <matthew@centricular.com>2015-09-10 13:11:06 +1000
commit38d360675c450ca8f89af6c42d1d0a2e85434437 (patch)
tree89a34502e7bd074b82b7738602ea8608812c0f3d /configure.ac
parent85745d2f639009f4e4519f09c1fd564891cd9173 (diff)
gtk, qt: more specifically define the compile time requirements
Otherwise we could include headers/configurations that will never been installed. https://bugzilla.gnome.org/show_bug.cgi?id=754732
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 35 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 4242b355f..bb41c15d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2617,16 +2617,31 @@ HAVE_GTK3_GL="no"
translit(dnm, m, l) AM_CONDITIONAL(USE_GTK3, true)
AG_GST_CHECK_FEATURE(GTK3, [Gtk+ elements], gtk, [
PKG_CHECK_MODULES(GTK3, gtk+-3.0, [
- AC_DEFINE([HAVE_GTK3], 1, [Define if Gtk+ 3.0 is installed])
- HAVE_GTK3="yes"
+ AC_DEFINE([HAVE_GTK3], 1, [Define if Gtk+ 3.0 is installed])
+ HAVE_GTK3="yes"
], [
- HAVE_GTK3="no"
+ HAVE_GTK3="no"
])
PKG_CHECK_MODULES(GTK3_GL, gtk+-3.0 >= 3.15.0, [
+ GDK_WINDOWING="no"
+ if test "x$GST_GL_HAVE_WINDOW_X11" = "x1" -a "x$GST_GL_HAVE_PLATFORM_GLX" = "x1"; then
+ PKG_CHECK_MODULES(GTK3_X11, gtk+-x11-3.0, [
+ GTK3_CFLAGS="$GTK3_CFLAGS $GTK3_X11_CFLAGS"
+ GTK3_LIBS="$GTK3_LIBS $GTK3_X11_LIBS"
+ GDK_WINDOWING="yes"
+ ], [AC_MSG_NOTICE([Could not find Gtk X11 integration])])
+ fi
+ if test "x$GST_GL_HAVE_WINDOW_WAYLAND" = "x1" -a "x$GST_GL_HAVE_PLATFORM_EGL" = "x1"; then
+ PKG_CHECK_MODULES(GTK3_WAYLAND, gtk+-wayland-3.0, [
+ GTK3_CFLAGS="$GTK3_CFLAGS $GTK3_WAYLAND_CFLAGS"
+ GTK3_LIBS="$GTK3_LIBS $GTK3_WAYLAND_LIBS"
+ GDK_WINDOWING="yes"
+ ], [AC_MSG_NOTICE([Could not find Gtk Wayland integration])])
+ fi
+ if test "x$GDK_WINDOWING" = "xyes"; then
AC_DEFINE([HAVE_GTK3_GL], 1, [Define if Gtk+ 3.0 GL is installed])
- if test "x$HAVE_GL" = "xyes"; then
- HAVE_GTK3_GL="yes"
- fi
+ HAVE_GTK3_GL="yes"
+ fi
], [
HAVE_GTK3_GL="no"
])
@@ -2648,19 +2663,23 @@ AG_GST_CHECK_FEATURE(QT, [Qt elements], qt, [
else
HAVE_QT="yes"
HAVE_QT_WINDOWING="no"
- PKG_CHECK_MODULES(QT_X11, Qt5X11Extras, [
- AC_DEFINE([HAVE_QT_X11], [], [Define if Qt X11 integration is installed])
+ if test "x$GST_GL_HAVE_WINDOW_X11" = "x1" -a "x$GST_GL_HAVE_PLATFORM_GLX" = "x1"; then
+ PKG_CHECK_MODULES(QT_X11, Qt5X11Extras, [
+ AC_DEFINE([HAVE_QT_X11], [], [Define if Qt X11 integration is installed])
QT_CFLAGS="$QT_CFLAGS $QT_X11_CFLAGS"
QT_LIBS="$QT_LIBS $QT_X11_LIBS"
HAVE_QT_WINDOWING="yes"
- ], [AC_MSG_NOTICE([Could not find Qt X11 integration])])
- PKG_CHECK_MODULES(QT_WAYLAND, Qt5WaylandClient, [
- AC_DEFINE([HAVE_QT_WAYLAND], [],
- [Define if Qt Wayland integration is installed])
- QT_CFLAGS="$QT_CFLAGS $QT_WAYLAND_CFLAGS"
- QT_LIBS="$QT_LIBS $QT_WAYLAND_LIBS"
- HAVE_QT_WINDOWING="yes"
- ], [AC_MSG_NOTICE([Could not find Qt Wayland integration])])
+ ], [AC_MSG_NOTICE([Could not find Qt X11 integration])])
+ fi
+ if test "x$GST_GL_HAVE_WINDOW_WAYLAND" = "x1" -a "x$GST_GL_HAVE_PLATFORM_EGL" = "x1"; then
+ PKG_CHECK_MODULES(QT_WAYLAND, Qt5WaylandClient, [
+ AC_DEFINE([HAVE_QT_WAYLAND], [],
+ [Define if Qt Wayland integration is installed])
+ QT_CFLAGS="$QT_CFLAGS $QT_WAYLAND_CFLAGS"
+ QT_LIBS="$QT_LIBS $QT_WAYLAND_LIBS"
+ HAVE_QT_WINDOWING="yes"
+ ], [AC_MSG_NOTICE([Could not find Qt Wayland integration])])
+ fi
if test "x$HAVE_QT_WINDOWING" = "xno"; then
AC_MSG_WARN([Could not find any Qt Windowing integration])
HAVE_QT="no"