summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUri Lublin <uril@redhat.com>2013-11-03 11:28:57 +0200
committerUri Lublin <uril@redhat.com>2013-11-13 10:24:59 +0200
commit750a8bab405588d91c41f84c458d9cda0f7189bf (patch)
treeb715ad4116e40be857217d03dd9ca1463f575270 /Makefile.am
parentfac9e8d3bf3d3b90d4c20e5c114430ea1781b2f7 (diff)
vdagent: add as_user to run tasks with user privileges
The class calls Impersonate upon begin(), and Revert upon end() or destruction. The user is the current user that is logged in. create mode 100644 vdagent/as_user.cpp create mode 100644 vdagent/as_user.h
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f907031..768e984 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,8 @@ vdagent_SOURCES = \
vdagent/file_xfer.cpp \
vdagent/file_xfer.h \
vdagent/vdagent.cpp \
+ vdagent/as_user.cpp \
+ vdagent/as_user.h \
$(NULL)
vdagent_rc.$(OBJEXT): vdagent/vdagent.rc