summaryrefslogtreecommitdiff
path: root/spice-gtk-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'spice-gtk-build.patch')
-rw-r--r--spice-gtk-build.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/spice-gtk-build.patch b/spice-gtk-build.patch
new file mode 100644
index 0000000..3ad6621
--- /dev/null
+++ b/spice-gtk-build.patch
@@ -0,0 +1,19 @@
+diff -up spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c.glib-build spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c
+--- spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c.glib-build 2011-02-11 11:55:51.188263533 -0500
++++ spice-gtk-0.5/spice-gtk3-0.5/gtk/spice-session.c 2011-02-11 11:56:05.478084885 -0500
+@@ -984,7 +984,6 @@ int spice_session_get_connection_id(Spic
+ return s->connection_id;
+ }
+
+-#if !GLIB_CHECK_VERSION(2,28,0)
+ static guint64 g_get_monotonic_clock(void)
+ {
+ GTimeVal tv;
+@@ -994,7 +993,6 @@ static guint64 g_get_monotonic_clock(voi
+
+ return (((gint64) tv.tv_sec) * 1000000) + tv.tv_usec;
+ }
+-#endif
+
+ G_GNUC_INTERNAL
+ guint32 spice_session_get_mm_time(SpiceSession *session)