summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-05-19 17:18:29 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2011-05-19 17:19:22 +0200
commit7c45bec07cf946a4782c2ea8e0a00146c48c2610 (patch)
tree05de2604fe6842d3ceeedb5dc847bb11e953f24d
parent8b607a684125ec2824a45d0b87e5632a29daaec5 (diff)
add patch to fix build of spice-gtk-0.6
spice-protocol as available in fedora 15 is missing a #include <stdint.h> which breaks the build of the controller
-rw-r--r--spice-gtk-controller-includes.patch20
-rw-r--r--spice-gtk.spec4
2 files changed, 24 insertions, 0 deletions
diff --git a/spice-gtk-controller-includes.patch b/spice-gtk-controller-includes.patch
new file mode 100644
index 0000000..e138587
--- /dev/null
+++ b/spice-gtk-controller-includes.patch
@@ -0,0 +1,20 @@
+--- a/gtk/controller/controller.c
++++ b/gtk/controller/controller.c
+@@ -15,6 +15,7 @@
+
+ #include <glib.h>
+ #include <glib-object.h>
++#include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <spice/controller_prot.h>
+--- a/gtk/controller/menu.c
++++ b/gtk/controller/menu.c
+@@ -15,6 +15,7 @@
+
+ #include <glib.h>
+ #include <glib-object.h>
++#include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <spice/controller_prot.h>
diff --git a/spice-gtk.spec b/spice-gtk.spec
index c8010d2..7fb1bb9 100644
--- a/spice-gtk.spec
+++ b/spice-gtk.spec
@@ -37,6 +37,7 @@ BuildRequires: libtool
ExclusiveArch: %{ix86} x86_64
+Patch0: spice-gtk-controller-includes.patch
%description
Client libraries for SPICE desktop servers.
@@ -117,6 +118,9 @@ snappy is a tool to capture screen-shots of a SPICE desktop.
%prep
%setup -q -n spice-gtk-%{version} -c
+pushd spice-gtk-%{version}
+%patch0 -p1 -b .controller-includes
+popd
%if %{with_gtk3}
cp -a spice-gtk-%{version} spice-gtk3-%{version}