summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2011-01-27 22:18:26 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2011-01-27 22:19:11 +0100
commit42cd64c65514ed14f819194f2cbe393026539239 (patch)
treef34953d014d3af146c52d747c6bf42ff17404334
parente4e62da9cc1db5e4d504421ddbf83f02af115cea (diff)
Update for release 0.5-1
* Thu Jan 27 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.5-1 - Upstream release 0.5 * Fri Jan 14 2011 Daniel P. Berrange <berrange@redhat.com> - 0.4-2 - Add support for parallel GTK3 build
-rw-r--r--.gitignore1
-rw-r--r--sources2
-rw-r--r--spice-gtk.spec150
3 files changed, 132 insertions, 21 deletions
diff --git a/.gitignore b/.gitignore
index 69cfb40..8df17e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/spice-gtk-0.4.tar.bz2
+/spice-gtk-0.5.tar.bz2
diff --git a/sources b/sources
index f347354..4efd5ff 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-d7ea131295ee0885b09ab9613069e20c spice-gtk-0.4.tar.bz2
+872b8d50ab85f01768bf83e074626f3f spice-gtk-0.5.tar.bz2
diff --git a/spice-gtk.spec b/spice-gtk.spec
index 6a084c9..9ed08b6 100644
--- a/spice-gtk.spec
+++ b/spice-gtk.spec
@@ -4,10 +4,15 @@
%filter_setup
}
+%define with_gtk3 0
+%if 0%{fedora} >= 15
+%define with_gtk3 1
+%endif
+
Name: spice-gtk
-Version: 0.4
-Release: 2%{?dist}
-Summary: A GTK widget for SPICE clients
+Version: 0.5
+Release: 1%{?dist}
+Summary: A GTK2 widget for SPICE clients
Group: System Environment/Libraries
License: LGPLv2+
@@ -24,6 +29,11 @@ BuildRequires: celt051-devel pulseaudio-libs-devel
BuildRequires: pygtk2-devel python-devel zlib-devel
BuildRequires: gobject-introspection-devel
BuildRequires: gtk-doc
+%if %{with_gtk3}
+BuildRequires: gtk3-devel
+%endif
+# Hack because of bz #613466
+BuildRequires: libtool
ExclusiveArch: %{ix86} x86_64
@@ -31,27 +41,69 @@ ExclusiveArch: %{ix86} x86_64
Client libraries for SPICE desktop servers.
%package devel
-Summary: Development files to build GTK2 applications with spice-gtk
+Summary: Development files to build GTK2 applications with spice-gtk-2.0
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
+Requires: spice-glib-devel = %{version}-%{release}
Requires: pkgconfig
Requires: gtk2-devel
%description devel
-spice-client-glib is a SPICE client library for GLib.
-spice-client-gtk provides a SPICE viewer widget for GTK.
+spice-client-gtk-2.0 provides a SPICE viewer widget for GTK2.
+
+Libraries, includes, etc. to compile with the spice-gtk2 libraries
+
+%package -n spice-glib
+Summary: A GObject for communicating with Spice servers
+Group: Development/Libraries
+
+%description -n spice-glib
+spice-client-glib-2.0 is a SPICE client library for GLib2.
+
+%package -n spice-glib-devel
+Summary: Development files to build Glib2 applications with spice-glib-2.0
+Group: Development/Libraries
+Requires: spice-glib = %{version}-%{release}
+Requires: pkgconfig
+Requires: glib2-devel
+
+%description -n spice-glib-devel
+spice-client-glib-2.0 is a SPICE client library for GLib2.
+
+Libraries, includes, etc. to compile with the spice-glib-2.0 libraries
+
+
+%if %{with_gtk3}
+%package -n spice-gtk3
+Summary: A GTK2 widget for SPICE clients
+Group: Development/Libraries
+
+%description -n spice-gtk3
+spice-client-glib-3.0 is a SPICE client library for Gtk3.
+
+%package -n spice-gtk3-devel
+Summary: Development files to build GTK2 applications with spice-gtk-3.0
+Group: Development/Libraries
+Requires: spice-gtk3 = %{version}-%{release}
+Requires: spice-glib-devel = %{version}-%{release}
+Requires: pkgconfig
+Requires: gtk3-devel
+
+%description -n spice-gtk3-devel
+spice-client-gtk-3.0 provides a SPICE viewer widget for GTK3.
-Libraries, includes, etc. to compile with the spice-gtk libraries
+Libraries, includes, etc. to compile with the spice-gtk3 libraries
+%endif
%package python
-Summary: Python bindings for the spice-gtk library
+Summary: Python bindings for the spice-gtk-2.0 library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description python
-SpiceClientGtk module provides a SPICE viewer widget for GTK.
+SpiceClientGtk module provides a SPICE viewer widget for GTK2.
-A module allowing use of the spice-gtk widget from python
+A module allowing use of the spice-gtk-2.0 widget from python
%package tools
Summary: Spice-gtk tools
@@ -63,17 +115,40 @@ spicy is a client to a SPICE desktop server.
snappy is a tool to capture screen-shots of a SPICE desktop.
%prep
-%setup -q
+%setup -q -n spice-gtk-%{version} -c
+%if %{with_gtk3}
+cp -a spice-gtk-%{version} spice-gtk3-%{version}
+%endif
%build
-%configure --enable-gtk-doc
+
+cd spice-gtk-%{version}
+%configure --enable-gtk-doc --with-gtk=2.0
+make %{?_smp_mflags}
+cd ..
+
+%if %{with_gtk3}
+cd spice-gtk3-%{version}
+%configure --with-gtk=3.0
make %{?_smp_mflags}
+cd ..
+%endif
%install
rm -rf %{buildroot}
+
+%if %{with_gtk3}
+cd spice-gtk3-%{version}
make install DESTDIR=%{buildroot}
+cd ..
+%endif
+
+cd spice-gtk-%{version}
+make install DESTDIR=%{buildroot}
+cd ..
+
rm -f %{buildroot}%{_libdir}/*.a
rm -f %{buildroot}%{_libdir}/*.la
rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
@@ -89,28 +164,63 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc AUTHORS COPYING README NEWS
-%{_libdir}/libspice-client-g*.so.*
-%{_libdir}/girepository-1.0/SpiceClientG*-1.0.typelib
+%doc spice-gtk-%{version}/AUTHORS
+%doc spice-gtk-%{version}/COPYING
+%doc spice-gtk-%{version}/README
+%doc spice-gtk-%{version}/NEWS
+%{_libdir}/libspice-client-gtk-2.0.so.*
+%{_libdir}/girepository-1.0/SpiceClientGtk-2.0.typelib
%files devel
%defattr(-,root,root,-)
-%{_libdir}/libspice-client-g*.so
-%{_includedir}/spice-client-g*
-%{_libdir}/pkgconfig/spice-client-g*.pc
-%{_datadir}/gir-1.0/SpiceClientG*-1.0.gir
+%{_libdir}/libspice-client-gtk-2.0.so
+%{_includedir}/spice-client-gtk-2.0
+%{_libdir}/pkgconfig/spice-client-gtk-2.0.pc
+%{_datadir}/gir-1.0/SpiceClientGtk-2.0.gir
+
+%files -n spice-glib -f %{name}.lang
+%defattr(-,root,root,-)
+%{_libdir}/libspice-client-glib-2.0.so.*
+%{_libdir}/girepository-1.0/SpiceClientGLib-2.0.typelib
+
+%files -n spice-glib-devel
+%defattr(-,root,root,-)
+%{_libdir}/libspice-client-glib-2.0.so
+%{_includedir}/spice-client-glib-2.0
+%{_libdir}/pkgconfig/spice-client-glib-2.0.pc
+%{_datadir}/gir-1.0/SpiceClientGLib-2.0.gir
%doc %{_datadir}/gtk-doc/html/*
+%if %{with_gtk3}
+%files -n spice-gtk3
+%defattr(-,root,root,-)
+%{_libdir}/libspice-client-gtk-3.0.so.*
+%{_libdir}/girepository-1.0/SpiceClientGtk-3.0.typelib
+
+%files -n spice-gtk3-devel
+%defattr(-,root,root,-)
+%{_libdir}/libspice-client-gtk-3.0.so
+%{_includedir}/spice-client-gtk-3.0
+%{_libdir}/pkgconfig/spice-client-gtk-3.0.pc
+%{_datadir}/gir-1.0/SpiceClientGtk-3.0.gir
+%endif
+
%files python
%defattr(-,root,root,-)
%{_libdir}/python*/site-packages/SpiceClientGtk.so
-%files tools -f %{name}.lang
+%files tools
%defattr(-,root,root,-)
%{_bindir}/snappy
%{_bindir}/spicy
%changelog
+* Thu Jan 27 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.5-1
+- Upstream release 0.5
+
+* Fri Jan 14 2011 Daniel P. Berrange <berrange@redhat.com> - 0.4-2
+- Add support for parallel GTK3 build
+
* Mon Jan 10 2011 Dan Horák <dan[at]danny.cz> - 0.4-2
- add ExclusiveArch as only x86 is supported