summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-01-29 15:58:42 +0100
committerArjun Roy <arroy@redhat.com>2010-02-03 11:45:03 -0800
commit96b1783ce573893bfd34e2ad5cd0a975480e6cc2 (patch)
tree872ae7426ea20c6c577f12dbb67bf86c188ef46a /Makefile.am
parent978da2ed2171a58d53374eb017bc7c9a83081950 (diff)
autoconfiscate
* Makefile.am: New file. * configure.ac: New file. * Makefile: Remove. * .gitignore: List ignorable files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..abfa713
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,49 @@
+
+AM_CPPFLAGS = -I$(top_srcdir)/inc $(LIBXML_CFLAGS)
+libosinfo_la_LDFLAGS = $(LIBXML_LIBS)
+
+lib_LTLIBRARIES = libosinfo.la
+
+libosinfo_la_SOURCES = \
+ inc/libosinfo.h \
+ inc/osi_api_methods.h \
+ inc/osi_api_types.h \
+ src/list.h \
+ src/osi_common.c \
+ src/osi_dataread.c \
+ src/osi_device.c \
+ src/osi_filter.c \
+ src/osi_hv.c \
+ src/osi_internal_types.h \
+ src/osi_lib.c \
+ src/osi_os.c
+
+check_PROGRAMS = \
+ test/sample \
+ test/test-filter \
+ test/test-get_devices \
+ test/test-get_os \
+ test/test-manipulate_devices \
+ test/test-manipulate_hypervisor \
+ test/test-manipulate_library \
+ test/test-manipulate_os \
+ test/test-set_hypervisor \
+ test/test-skeleton
+
+EXTRA_DIST = \
+ data/libosinfo-dummy-data.xml
+
+LDADD = $(lib_LTLIBRARIES)
+
+generated_test_scripts = $(patsubst %,%.sh,$(check_PROGRAMS))
+TESTS = $(generated_test_scripts)
+
+DISTCLEANFILES = $(generated_test_scripts)
+
+test/%.sh: Makefile
+ printf '#!$(SHELL)\nexec $(*F) $(srcdir)/data\n' > $@-tmp
+ chmod a+x $@-tmp
+ mv $@-tmp $@
+
+TESTS_ENVIRONMENT = \
+ PATH='$(abs_top_builddir)/test$(PATH_SEPARATOR)'"$$PATH"