summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2011-12-14 16:35:04 -0500
committerPeng Huang <shawn.p.huang@gmail.com>2012-02-21 11:51:38 -0500
commit3e114c4cbbebbfdf89fd36dc74ed4cdb6f5004c2 (patch)
tree0210c36db951c5eb9da8c78f4a5274581d13dab1 /Makefile.am
parent0fb7788fb103da00d38f69b44ee63f78f3cda14e (diff)
WIP add a shell tool.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 30 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index e0c79bfb..ce478cf5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,53 +22,58 @@
NULL =
+UI_DIR = \
+ ui \
+ $(NULL)
+
if ENABLE_PYTHON
-PYTHON_DIRS = \
- ibus \
- ui \
- setup \
+PYTHON_DIRS = \
+ ibus \
+ setup \
$(NULL)
endif
if ENABLE_GCONF
-GCONF_DIRS = \
- gconf \
+GCONF_DIR = \
+ gconf \
$(NULL)
endif
if ENABLE_DAEMON
-DAEMON_DIRS = \
- bus \
+DAEMON_DIR = \
+ bus \
$(NULL)
endif
if ENABLE_MEMCONF
-MEMCONF_DIRS = \
+MEMCONF_DIR = \
memconf \
$(NULL)
endif
if ENABLE_DCONF
-DCONF_DIRS = \
+DCONF_DIR = \
dconf \
$(NULL)
endif
-SUBDIRS = \
- src \
- util \
- client \
- engine \
- data \
- m4 \
- po \
- docs \
- bindings \
- $(DAEMON_DIRS) \
- $(PYTHON_DIRS) \
- $(GCONF_DIRS) \
- $(MEMCONF_DIRS) \
- $(DCONF_DIRS) \
+SUBDIRS = \
+ src \
+ util \
+ client \
+ engine \
+ tools \
+ data \
+ m4 \
+ po \
+ docs \
+ bindings \
+ $(UI_DIR) \
+ $(DAEMON_DIR) \
+ $(GCONF_DIR) \
+ $(MEMCONF_DIR) \
+ $(DCONF_DIR) \
+ $(PYTHON_DIRS) \
$(NULL)
ACLOCAL_AMFLAGS = -I m4