summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..f53273a
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,17 @@
+noinst_PROGRAMS = $(TESTS)
+
+AM_LDFLAGS = \
+ $(top_builddir)/govirt/libgovirt.la \
+ $(GLIB_LIBS)
+
+
+AM_CFLAGS = \
+ $(WARNINGFLAGS_C) \
+ $(GLIB_CFLAGS) \
+ $(REST_CFLAGS) \
+ -Dabs_srcdir="\"$(abs_srcdir)\"" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/govirt
+
+noinst_LTLIBRARIES = libmock-httpd.la
+libmock_httpd_la_SOURCES = mock-httpd.c mock-httpd.h