summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-04 20:29:14 +0100
committerStef Walter <stefw@gnome.org>2013-03-04 20:29:14 +0100
commit7afaae43f205c059163c3670169af302f1ba6de3 (patch)
treeb3e461e27102336ed0f43b250d56c0b206d4898c /configure.ac
parentddb87ccad91a6ee0591439b40cbf199123a394c7 (diff)
pkcs11: Remove the roots-store now provided by p11-kit
This module is replaced by the p11-kit-trust module installed with p11-kit 0.16 and later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 953d318a..1e9c1445 100644
--- a/configure.ac
+++ b/configure.ac
@@ -349,52 +349,6 @@ fi
AM_CONDITIONAL(WITH_GPG, test "$enable_gpg_agent" != "no")
# --------------------------------------------------------------------
-# Trusted Root Certificates Directory
-#
-
-AC_MSG_CHECKING([location of system Certificate Authority list])
-
-AC_ARG_WITH(root-certs,
- [AC_HELP_STRING([--with-root-certs=@<:@path@:>@],
- [directory for system Certificate Authorities])])
-
-AC_ARG_WITH(ca-certificates,
- [AC_HELP_STRING([--with-ca-certificates=@<:@path@:>@],
- [file for system Certificate Authorities])])
-
-# Explicitly disabled root certificate authority list
-if test "$with_root_certs" = "no" -o "$with_ca_certificates" = "no"; then
- root_status="disabled"
-
-# A directory specified for the root certificate authority list
-elif test -n "$with_root_certs"; then
- AC_DEFINE_UNQUOTED(ROOT_CA_DIRECTORY, ["$with_root_certs"], [Directory path for CA list])
- root_status="directory: $with_root_certs"
-
-# A file specified for the root certificate list
-elif test -n "$with_ca_certificates"; then
- AC_DEFINE_UNQUOTED(ROOT_CA_FILE, ["$with_ca_certificates"], [File path for CA list])
- root_status="file: $with_ca_certificates"
-
-# Automatically find certificate authority list
-else
- for f in /etc/pki/tls/certs/ca-bundle.crt \
- /etc/ssl/certs/ca-certificates.crt; do
- if test -f "$f"; then
- with_ca_certificates="$f"
- fi
- done
- if test -z "$with_ca_certificates"; then
- AC_MSG_ERROR([could not find. Use --with-ca-certificates=path to set, or --without-ca-certificates to disable])
- fi
-
- AC_DEFINE_UNQUOTED(ROOT_CA_FILE, ["$with_ca_certificates"], [File path for CA list])
- root_status="file: $with_ca_certificates"
-fi
-
-AC_MSG_RESULT(["$root_status"])
-
-# --------------------------------------------------------------------
# libgcrypt
#
@@ -701,8 +655,6 @@ pkcs11/gkm/Makefile
pkcs11/gkm/tests/Makefile
pkcs11/gnome2-store/Makefile
pkcs11/gnome2-store/tests/Makefile
-pkcs11/roots-store/Makefile
-pkcs11/roots-store/tests/Makefile
pkcs11/rpc-layer/Makefile
pkcs11/rpc-layer/gnome-keyring.module
pkcs11/secret-store/Makefile