summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-09-26 15:22:49 +0200
committerStef Walter <stefw@collabora.co.uk>2011-09-26 15:39:05 +0200
commitf575afb81aad66d66cb969aab52e4180ce811014 (patch)
tree1c7067cdf4161a4b604ccc767d9f1a5ecc8e24cd /Makefile.am
parentc9c33166230fbac29eb49f5e5c34337a0f4fdf6d (diff)
Rework configure build options based on recent mailing list posts
* --enable-strict to enable -Werror, fatal warnings and disable deprecations * --disable-debug to G_DISABLE_ASSERT * default debug for -g, WITH_DEBUG * --enable-debug to -OO
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 57981f9e..ed9db2da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,12 +4,6 @@ else
PAM_DIR =
endif
-if WITH_TESTS
-TESTS_DIR = testing
-else
-TESTS_DIR =
-endif
-
SUBDIRS = \
. \
egg \
@@ -20,7 +14,7 @@ SUBDIRS = \
schema \
daemon \
tool \
- $(TESTS_DIR) \
+ testing \
$(PAM_DIR) \
po \
docs
@@ -36,9 +30,8 @@ EXTRA_DIST = \
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
- --enable-tests=full \
- --enable-debug=yes \
- --disable-gcov \
+ --enable-strict \
+ --disable-coverage \
--disable-update-mime \
--with-pkcs11-modules=$(abs_srcdir)/$(top_distdir)/_inst/lib/