summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2010-09-18 17:14:47 +0000
committerStef Walter <stef@memberwebs.com>2010-09-18 17:24:14 +0000
commita2ab14444d1256ef75e7d08c119b2cbe3a86330b (patch)
treeade31dccdc381614775773e6bde049091bc706cc /Makefile.am
parenta2cd618604d6b5f599e0e6452c5adb596cba43ff (diff)
Make coverage targets more modular.
Run 'make clear' before starting running stuff you want in coverage, and then 'make coverage' for the report.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ef55416c..84a1ee43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,10 +64,10 @@ install-pam:
@echo "WARNING: install-pam is no longer used, use the --with-pam-dir configure option instead"
if WITH_COVERAGE
-check-am:
+clear:
$(LCOV) --directory . --zerocounters
-coverage: check
+coverage:
mkdir -p testing/coverage
$(LCOV) --directory . --capture --output-file testing/coverage.info
$(GENHTML) --output-directory testing/coverage testing/coverage.info