summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2011-01-04 16:55:12 -0600
committerStef Walter <stef@memberwebs.com>2011-01-19 12:40:33 -0600
commit5696161ae6c543457c092c807e6129646b896676 (patch)
tree100ebfa060be361ff30e62ad444e518af5afc72e /Makefile.am
parent982a0df6b8205322c47828c27d351263554fc1d9 (diff)
Remove any coverage files from docs directory before prepping coverage.
Otherwise we'd get errors about missing source files and the like when doing 'make coverage'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5356b42c..c2dbf8ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ install-pam:
if WITH_COVERAGE
coverage:
mkdir -p testing/coverage
+ $(LCOV) --directory docs/ --zerocounters
$(LCOV) --directory . --capture --output-file testing/coverage.info
$(GENHTML) --output-directory testing/coverage testing/coverage.info
$(LCOV) --directory . --zerocounters
@@ -79,4 +80,4 @@ endif
if WITH_GNU_MAKE
# Include this local file if it exists
-include Makefile.local
-endif \ No newline at end of file
+endif