summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Facchini <stefano.facchini@gmail.com>2012-01-19 13:15:15 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2012-01-19 17:19:09 +0100
commit30391a7ca03f612954cc53ac9095b8d0db97ecdf (patch)
treeb421ea3785ad0a315b7a5620ac32b1191308b9cb /Makefile.am
parent7c340775d9ea64a788d32e947d5df7fb7e90b78a (diff)
build: improve the build from vala
https://bugzilla.gnome.org/show_bug.cgi?id=668104
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b61f58e..cccf884 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@ EXTRA_DIST = \
CodingStyle.txt \
THANKS \
build-aux/git-version-gen \
+ m4/boxes.m4 \
.version \
$(INTLTOOL_FILES) \
$(NULL)
@@ -30,7 +31,6 @@ MAINTAINERCLEANFILES = \
ABOUT-NLS \
aclocal.m4 \
config.h.in \
- m4/*.m4 \
build-aux/compile \
build-aux/config.guess \
build-aux/config.rpath \
@@ -64,4 +64,7 @@ all: version.h
version.h: $(top_srcdir)/.version
echo '#define BUILD_VERSION "'`cat $(top_srcdir)/.version`'"' > $@-t && mv $@-t $@
+vala-clean:
+ rm -f `find . -name "*.stamp"`
+
-include $(top_srcdir)/git.mk