summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2014-03-02 15:14:19 +0100
committerStef Walter <stefw@gnome.org>2014-03-03 08:17:55 +0100
commite1b2825190707853b715069f7eb0b955f57fae8e (patch)
tree170fa617a6447355b248da0c81afdf61b7f1b587 /configure.ac
parent44b5f6a0a5e9567ea8321084a93fc19f8669dd6a (diff)
Gcr-3.gir: Unbreak virtual-method output for GcrCertificate.get_der_data
See https://bugzilla.gnome.org/show_bug.cgi?id=725501 for more details.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52b4f4e..2e48d29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,12 +89,18 @@ AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
GLIB_GSETTINGS
-GOBJECT_INTROSPECTION_CHECK([1.34])
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
AC_PATH_PROG(GLIB_MKENUMS, glib-mkenums)
GTK_DOC_CHECK(1.9)
+GOBJECT_INTROSPECTION_CHECK([1.34])
+if test "$enable_introspection" = "yes"; then
+ AC_PATH_PROG(XSLTPROC, xsltproc,
+ AC_MSG_ERROR([Need xsltproc in order to build with gobject introspection])
+ )
+fi
+
# --------------------------------------------------------------------
# Optional GTK+ widgets build, avoid building gtk-doc wihtout GTK+
#