summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorR. Bernstein <rocky@gnu.org>2012-09-27 06:57:34 -0400
committerR. Bernstein <rocky@gnu.org>2012-09-27 06:57:34 -0400
commite4b2af0f00d6f033f7aa2dc1b117a7324e4169ae (patch)
tree5dd832c1e26e583160278322c45f9a481c21000e /configure.ac
parent3f0ad681bde2f4e59f461ee90ddb0bbe5784370a (diff)
Recalculate native_top_srcdir one more time
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 27502403..6bb7a843 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,9 +333,16 @@ dnl Libtool flag for strict linkage
LT_NO_UNDEFINED=
dnl regression tests need native-style absolute paths.
-dnl native_srcdir is used here.
-native_top_srcdir=$(cd $srcdir; /bin/bash.exe -c 'builtin pwd -W')
-AC_SUBST(native_top_srcdir)
+dnl native_abs_top_srcdir is used here.
+case $srcdir in
+ .) # We are building in place.
+ native_abs_top_srcdir=$ac_pwd ;;
+ [\\/]* | ?:[\\/]* ) # Absolute name.
+ native_abs_top_srcdir=$srcdir ;;
+ *) # Relative name.
+ native_abs_top_srcdir=$ac_pwd/$srcdir ;;
+esac
+AC_SUBST(native_abs_top_srcdir)
case $host_os in
aix*)