summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorflameeyes <flameeyes>2007-11-16 21:49:20 +0000
committerflameeyes <flameeyes>2007-11-16 21:49:20 +0000
commitcfd38185bf01edf5a6e4bfb3938b0d342c1c1ccb (patch)
treed2d5e94a909b7f3e146a677db1a8800db0577a7d /Makefile.am
parentab133c5fc52c4520f75de2689888dcb65891b897 (diff)
Do not install the libcdio_paranoia.pc and libcdio_cdda.pc files if cd-paranoia is not built.
If we do, the pkg-config based checks will report the presence of libraries that are not present in the system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index fb527281..5a1a1c7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am,v 1.39 2006/03/18 03:19:16 rocky Exp $
+# $Id: Makefile.am,v 1.40 2007/11/16 21:49:20 flameeyes Exp $
#
# Copyright (C) 2003, 2004, 2006 Rocky Bernstein <rocky@panix.com>
#
@@ -39,10 +39,15 @@ EXTRA_DIST = \
SUBDIRS = doc include lib src test example
+if BUILD_CD_PARANOIA
+paranoiapcs = libcdio_paranoia.pc libcdio_cdda.pc
+endif
+
# pkg-config(1) related rules
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libcdio.pc libcdio_paranoia.pc \
- libcdio_cdda.pc libiso9660.pc
+pkgconfig_DATA = libcdio.pc libiso9660.pc \
+ $(paranoiapcs)
+
$(pkgconfig_DATA): config.status