summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Chimento <philip.chimento@gmail.com>2016-11-09 21:22:53 -0800
committerTanu Kaskinen <tanuk@iki.fi>2017-01-19 03:00:45 +0200
commit8405b1fb7f03ca11512321df1e9ed8fc806dc662 (patch)
tree5c1a9f05da4bc05a1b056cc38a2ab5afb125aea4 /configure.ac
parenta4bc0227b3fb567234b2251a7ee8189672514cc9 (diff)
build-sys: Move TLS check after flags additions
Any compiler flags should be set before asking the compiler to check for thread-local storage with AX_TLS, since compiler flags (in this case -mmacosx-version-min=10.5) can influence the outcome of that check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 65a9ebaa..7a87432f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -502,20 +502,6 @@ AC_CACHE_CHECK([whether $CC knows _Bool],
AS_IF([test "$pulseaudio_cv__Bool" = "yes"], AC_DEFINE([HAVE_STD_BOOL], 1, [Have _Bool.]))
-#### Thread support ####
-
-AX_TLS
-AS_IF([test "$ac_cv_tls" = "__thread"],
- AC_DEFINE([SUPPORT_TLS___THREAD], 1, [Define this if the compiler supports __thread for Thread-Local Storage]))
-
-# Win32 build breaks with win32 pthread installed
-AS_IF([test "x$os_is_win32" != "x1"],
- [AX_PTHREAD])
-
-AS_IF([test "x$ax_pthread_ok" = "xyes"],
- AC_DEFINE([_POSIX_PTHREAD_SEMANTICS], 1, [Needed on Solaris]))
-
-
#### Check for libs ####
# ISO
@@ -1405,6 +1391,20 @@ AS_IF([test "x$enable_adrian_aec" != "xno"],
AM_CONDITIONAL([HAVE_ADRIAN_EC], [test "x$HAVE_ADRIAN_EC" = "x1"])
+#### Thread support ####
+
+AX_TLS
+AS_IF([test "$ac_cv_tls" = "__thread"],
+ AC_DEFINE([SUPPORT_TLS___THREAD], 1, [Define this if the compiler supports __thread for Thread-Local Storage]))
+
+# Win32 build breaks with win32 pthread installed
+AS_IF([test "x$os_is_win32" != "x1"],
+ [AX_PTHREAD])
+
+AS_IF([test "x$ax_pthread_ok" = "xyes"],
+ AC_DEFINE([_POSIX_PTHREAD_SEMANTICS], 1, [Needed on Solaris]))
+
+
###################################
# Output #