summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2016-01-25 10:16:56 -0800
committerEric Anholt <eric@anholt.net>2016-02-03 11:29:52 -0800
commit3c717f61f885240980bfc4273dbd1fc837edc391 (patch)
treedf61d1686c4d466251b059c6c576ee22a50a9439 /Makefile.am
parent0ad32e7ff48e106d654acca79445389651ed6909 (diff)
vc4: Add headers and .pc files for VC4 userspace development.
The headers were originally written in Mesa, imported to the kernel, and improved upon in vc4-gpu-tools. These come from the v-g-t copies and will replace the Mesa and v-g-t copies, and hopefully be used from new tests in igt, as well. v2: Fix linking against libdrm_intel instead of libdrm. v3: Drop Libs and Cflags since they'll be inherited from libdrm. v4: Switch to Requires.private. I was wrong about standard practice, apparently only Intel was doing plain Requires (sorry to all involved). Signed-off-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ca415089..feecba72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-radeon \
--enable-amdgpu \
--enable-nouveau \
+ --enable-vc4 \
--enable-vmwgfx \
--enable-omap-experimental-api \
--enable-exynos-experimental-api \
@@ -79,6 +80,10 @@ if HAVE_TEGRA
TEGRA_SUBDIR = tegra
endif
+if HAVE_VC4
+VC4_SUBDIR = vc4
+endif
+
if BUILD_MANPAGES
if HAVE_MANPAGES_STYLESHEET
MAN_SUBDIR = man
@@ -96,6 +101,7 @@ SUBDIRS = \
$(EXYNOS_SUBDIR) \
$(FREEDRENO_SUBDIR) \
$(TEGRA_SUBDIR) \
+ $(VC4_SUBDIR) \
tests \
$(MAN_SUBDIR)