summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRALOVICH, Kristof <tade60@freemail.hu>2014-04-05 11:48:42 +0200
committerRALOVICH, Kristof <tade60@freemail.hu>2014-04-05 11:48:42 +0200
commit8d2878344185b1f1cc3e26a4f2c96af4657fcdb0 (patch)
treee70ec10b1d2fab2d863233067eb26fc847ca5bfc
parent3270c84fd83c324d0c56710583a4493fd3a4a14f (diff)
debian: create package with debug symbols too
-rw-r--r--debian/control26
-rwxr-xr-xdebian/rules6
2 files changed, 30 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index b49b27d..360d85d 100644
--- a/debian/control
+++ b/debian/control
@@ -30,3 +30,29 @@ Description: ANT+ information retrieval client for Garmin GPS products
The software was originally named "gant" but renamed when packaged
to avoid confusion with existing Java software.
+
+Package: antpm-dbg
+Section: debug
+Priority: extra
+Architecture: any
+Depends:
+ antpm (= ${binary:Version}),
+ ${misc:Depends},
+Description: ANT+ information retrieval client for Garmin GPS products
+ This software uses the Garmin ANT+ proprietary USB keys and
+ communication protocol to retrieve information (such as GPS traces)
+ from some Garmin Forerunner watches such as Forerunner 405 and 310XT.
+ .
+ The underlying ANT+minus implements the ANT/ANT+/ANT-FS protocols to
+ provide these tools: garmin-ant-downloader, antpm-downloader,
+ antpm-fit2gpx, and antpm-usbmon2ant.
+ .
+ ANT+minus is a userspace implementation of a wire protocol similar
+ to the ANT/ANT+/ANT-FS protocols. The goal is to be able to communicate
+ with any ANT capable device in order to e.g. retrieve sports tracks. The
+ c++ implementation is currently available under both linux and win.
+ Communication with watches other than the 310XT might work, but are
+ untested. Please report your experience to help improving the software.
+ .
+ The software was originally named "gant" but renamed when packaged
+ to avoid confusion with existing Java software.
diff --git a/debian/rules b/debian/rules
index 6d961fe..e61c83f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,14 +18,16 @@ LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
dh $@
override_dh_auto_configure:
- # echo -e "\n\n\nCMAKE\n\n\n"
- # echo $(NUMCPUS)
mkdir cmake-build
cd cmake-build && cmake ../src -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_FLAGS="${CMAKE_C_FLAGS} $(CFLAGS)" -DCMAKE_CXX_FLAGS="${CMAKE_CXX_FLAGS} $(CXXFLAGS)"
override_dh_auto_build:
cd cmake-build && $(MAKE) -j$(NUMCPUS)
+override_dh_strip:
+ dh_strip --dbg-package=antpm-dbg
+ dh_strip -s --remaining-packages
+
DESTDIR=../debian/antpm/
override_dh_install:
cd cmake-build && $(MAKE) install DESTDIR=$(DESTDIR)