summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRALOVICH, Kristof <tade60@freemail.hu>2014-08-01 13:40:09 +0200
committerRALOVICH, Kristof <tade60@freemail.hu>2014-08-01 13:40:09 +0200
commit1f4696b571bfce9d1c5e6fcac94c23b495e5c64c (patch)
tree838b854582c33c92f0a99ed3a401025f7eef9309
parent622beb858fb7aea67a89b29c05cd3536624a3a2d (diff)
debian/rules: do not call make -j0
Fall back on non-parallel make to fix problems like: make[1]: Entering directory '/«PKGBUILDDIR»' cd cmake-build && /usr/bin/make -j0 make: Entering an unknown directory make: the '-j' option requires a positive integer argument Usage: make [options] [target] ... [...] This program built for sparc-unknown-linux-gnu Report bugs to <bug-make@gnu.org> make: Leaving an unknown directory make[1]: *** [override_dh_auto_build] Error 2 debian/rules:25: recipe for target 'override_dh_auto_build' failed make[1]: Leaving directory '/«PKGBUILDDIR»' make: *** [build-arch] Error 2 debian/rules:18: recipe for target 'build-arch' failed dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2 (from https://buildd.debian.org/status/fetch.php?pkg=antpm&arch=sparc&ver=1.16-4&stamp=1404308304)
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5234329..08a94c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,9 @@
export DH_VERBOSE=1
NUMCPUS=$(shell grep -c '^processor' /proc/cpuinfo)
+ifeq ($(NUMCPUS),0)
+ NUMCPUS=1
+endif
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)