summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-10-17 15:49:23 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-10-17 15:49:23 +0200
commita39a709d2d001a19059de304c16b96fe2d2f64fe (patch)
treeef422d093c2492ee9c063d0d55b20df67a1eb2eb /Makefile.am
parent1dea0ef9744a8ae35f293e24d7c190402f38b1a6 (diff)
debian: fix make dist for packaging.
bzip2 tarballs are now used, so update the deb.upstream dependencies to include dist-bzip2 instead of plain old dist, and use the correct tar extract options to handle that format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 08a5e2a8..70cb5eea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,11 +15,11 @@ DEB_BUILDDIR = debian.build
deb:
dpkg-buildpackage -rfakeroot -uc -us
-deb.upstream: dist
+deb.upstream: dist-bzip2
-mkdir -p $(DEB_BUILDDIR)
cd $(DEB_BUILDDIR) && \
rm -rf $(PACKAGE)-$(VERSION) && \
- tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
+ tar jxvf ../$(PACKAGE)-$(VERSION).tar.bz2 && \
cd $(PACKAGE)-$(VERSION) && \
$(LN_S) debian.upstream debian && \
$(MAKE) deb -f Makefile.am