summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-07-07 16:41:21 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-07-07 16:41:21 +0000
commit086b7e44e7c0a45f925501584a164217e3b61fd5 (patch)
treeba0f67a664b8a082f185491df2542c100178a840 /Makefile.am
parentf38bff62af57f0f5e20c770ee77d9fabb766c2ac (diff)
copy extra content files; make plugins-base use gtk-doc.mak
Original commit message from CVS: copy extra content files; make plugins-base use gtk-doc.mak
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 17 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ac9f657a..fe73f81ab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,27 +1,34 @@
if USE_GCONFTOOL
-GCONF_DIR = gconf
+SUBDIRS_GCONF = gconf
else
-GCONF_DIR =
+SUBDIRS_GCONF =
endif
if BUILD_EXTERNAL
-EXT_DIR = ext
+SUBDIRS_EXT = ext
else
-EXT_DIR =
+SUBDIRS_EXT =
endif
if BUILD_EXAMPLES
-EXAMPLES_DIR = examples
+SUBDIRS_EXAMPLES = examples
else
-EXAMPLES_DIR =
+SUBDIRS_EXAMPLES =
+endif
+
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
endif
SUBDIRS = \
gst-libs \
- gst sys $(EXT_DIR) \
- $(EXAMPLES_DIR) \
+ gst sys $(SUBDIRS_EXT) \
+ $(SUBDIRS_EXAMPLES) \
tools \
- $(GCONF_DIR) \
+ $(SUBDIRS_GCONF) \
+ $(SUBDIRS_CHECK) \
docs \
po \
common \
@@ -35,6 +42,7 @@ DIST_SUBDIRS = \
examples \
tools \
gconf \
+ check \
po \
common \
m4 \