summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier CrĂȘte <olivier.crete@collabora.com>2012-01-06 19:44:47 -0500
committerOlivier CrĂȘte <olivier.crete@collabora.com>2012-01-10 16:21:52 -0500
commit71aeae7522d43cdfc226936bff96909b5a6cf323 (patch)
tree5a40102dcc0473d7add28ec662acf6f10d8e7f22 /configure.ac
parent909ac13ef3b102be8f960a955187e69a9d3e9a82 (diff)
Port MediaManager to use Call instead of StreamedMedia
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14621e3..31468d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,18 @@ else
AM_CONDITIONAL([WANT_TWISTED_TESTS], false)
fi
+AC_ARG_ENABLE(channel-type-call,
+ AC_HELP_STRING([--enable-channel-type-call],
+ [enable support for the draft Channel.Type.Call]),
+ [enable_channel_type_call=$enableval], [enable_channel_type_call=no])
+
+if test x$enable_channel_type_call = xyes; then
+ AC_DEFINE(ENABLE_CHANNEL_TYPE_CALL, [], [Enable Channel.Type.Call])
+fi
+
+AM_CONDITIONAL(ENABLE_CHANNEL_TYPE_CALL, test x$enable_channel_type_call = xyes)
+
+
AC_CONFIG_FILES([
Makefile
rakia/Makefile