summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2010-08-17 15:52:03 -0300
committerJohan Dahlin <johan@gnome.org>2010-08-17 15:53:07 -0300
commit98ca5de2eeb098e5f256abd9938e5a40861b4f1e (patch)
treeefb6ce615e29c9d9d437bf7b853f538d347fdcbb /Makefile.am
parent8942500c99de223eff6f91677a5dff206e09b3a7 (diff)
Add a pre-commit hook and enforce it
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 98016cd..1c09fbb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,10 @@ upload-release: $(distdir).tar.gz
ssh gnome.org install-module $(distdir).tar.gz
check-local:
+ @test -f .git/hooks/pre-commit || (echo -e "ERROR: missing \
+ pre-commit hook.\n\ncopy misc/pre-commit to .git/hooks"; false)
+ @test -x .git/hooks/pre-commit || (echo -e "ERROR: pre-commit \
+ is not executable\n\nrun chmod +x .git/hooks/pre-commit"; false)
@echo " PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
@echo " CHECK Pyflakes"